aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/predixy/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/predixy/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/predixy/default.nix')
-rw-r--r--flakes/mypackages/pkgs/predixy/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/predixy/default.nix b/flakes/mypackages/pkgs/predixy/default.nix
new file mode 100644
index 0000000..259d7fd
--- /dev/null
+++ b/flakes/mypackages/pkgs/predixy/default.nix
@@ -0,0 +1,19 @@
1{ stdenv, fetchFromGitHub }:
2stdenv.mkDerivation ({
3 pname = "predixy";
4 version = "dacf3fb-master";
5 src = fetchFromGitHub {
6 owner = "joyieldInc";
7 repo = "predixy";
8 rev = "dacf3fb30c2602dc044040df04e194d44b49c1be";
9 sha256 = "0sbvy0jg551lwkfq8qh0a49cl9mhfnkhi3cnk25l8pz4jcdrr9k9";
10 fetchSubmodules = true;
11 };
12 installPhase = ''
13 mkdir -p $out/bin
14 cp src/predixy $out/bin
15 mkdir -p $out/share
16 cp -r doc $out/share
17 cp -r conf $out/share/doc
18 '';
19})