aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/notmuch/notmuch-python/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/notmuch/notmuch-python/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/notmuch/notmuch-python/default.nix')
-rw-r--r--flakes/mypackages/pkgs/notmuch/notmuch-python/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/notmuch/notmuch-python/default.nix b/flakes/mypackages/pkgs/notmuch/notmuch-python/default.nix
new file mode 100644
index 0000000..d639d9a
--- /dev/null
+++ b/flakes/mypackages/pkgs/notmuch/notmuch-python/default.nix
@@ -0,0 +1,16 @@
1{ stdenv, notmuch, pythonPackages }:
2stdenv.mkDerivation rec {
3 name = "notmuch-${pythonPackages.python.name}-${version}";
4 version = notmuch.version;
5 outputs = [ "out" ];
6 buildInputs = with pythonPackages; [ sphinx python ];
7 src = notmuch.src;
8 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
9 buildPhase = ''
10 cd bindings/python
11 python setup.py build
12 '';
13 installPhase = ''
14 python setup.py install --prefix=$out --optimize=1
15 '';
16}