aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/note/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/note/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/note/default.nix')
-rw-r--r--flakes/mypackages/pkgs/note/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/note/default.nix b/flakes/mypackages/pkgs/note/default.nix
new file mode 100644
index 0000000..b3b03ef
--- /dev/null
+++ b/flakes/mypackages/pkgs/note/default.nix
@@ -0,0 +1,19 @@
1{ lib, fetchurl, perlPackages }:
2perlPackages.buildPerlPackage rec {
3 pname = "note";
4 version = "1.3.26";
5 src = fetchurl {
6 url = "mirror://cpan/authors/id/T/TL/TLINDEN/${pname}-${version}.tar.gz";
7 sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
8 };
9 outputs = ["out" "man"];
10 propagatedBuildInputs = with perlPackages; [ YAML ];
11
12 meta = with lib; {
13 description = "A perl script for maintaining notes";
14 homepage = http://www.daemon.de/NOTE;
15 license = licenses.gpl3;
16 maintainers = with maintainers; [ { name = "T.v.Dein"; email = "tlinden@cpan.org"; } ];
17 platforms = platforms.unix;
18 };
19}