aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/nb/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/nb/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/nb/default.nix')
-rw-r--r--flakes/mypackages/pkgs/nb/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/nb/default.nix b/flakes/mypackages/pkgs/nb/default.nix
new file mode 100644
index 0000000..337c286
--- /dev/null
+++ b/flakes/mypackages/pkgs/nb/default.nix
@@ -0,0 +1,22 @@
1{ fetchFromGitHub, stdenv, makeWrapper, lib, file }:
2stdenv.mkDerivation {
3 pname = "nb";
4 version = "e0d4e24-master";
5 src = fetchFromGitHub {
6 owner = "xwmx";
7 repo = "nb";
8 rev = "e0d4e24201299916d736be6a9800793cec32927e";
9 sha256 = "0gpnlzxjlfn3bagw74lsrmfhxj2xzvk6sjj24wp9rjpk42d9mfml";
10 };
11 phases = "installPhase";
12 buildInputs = [ makeWrapper ];
13 installPhase = ''
14 mkdir -p $out/bin $out/share/zsh/vendor-completions $out/share/bash-completion/completions
15 cp $src/nb $out/bin/nb
16 chmod +x $out/bin/nb
17 patchShebangs $out/bin/nb
18 wrapProgram $out/bin/nb --prefix PATH : ${lib.makeBinPath [ file ]}
19 cp $src/etc/nb-completion.zsh $out/share/zsh/vendor-completions/_nb
20 cp $src/etc/nb-completion.bash $out/share/bash-completion/completions/nb
21 '';
22}