aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/nagnu/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/nagnu/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/nagnu/default.nix')
-rw-r--r--flakes/mypackages/pkgs/nagnu/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/nagnu/default.nix b/flakes/mypackages/pkgs/nagnu/default.nix
new file mode 100644
index 0000000..c7a1162
--- /dev/null
+++ b/flakes/mypackages/pkgs/nagnu/default.nix
@@ -0,0 +1,21 @@
1{ stdenv, fetchFromGitHub, ncurses, curl }:
2stdenv.mkDerivation (rec {
3 pname = "nagnu";
4 version = "c7e65fc-master";
5 src = fetchFromGitHub {
6 owner = "frlen";
7 repo = "nagnu";
8 rev = "c7e65fc02f46a3756a4cc47953ea2f3e57a84728";
9 sha256 = "1i2jm8ibvqcc734daamnzc3hx8q0nsry1x12q0kr5yvcsdjjgyy3";
10 fetchSubmodules = true;
11 };
12 buildInputs = [ ncurses curl ];
13 installPhase = ''
14 mkdir -p $out/bin
15 cp nagnu $out/bin
16 mkdir -p $out/share/doc/nagnu
17 cp nagnu.conf.sample $out/share/doc/nagnu
18 mkdir -p $out/share/man/man8
19 cp docs/nagnu.8 $out/share/man/man8
20 '';
21})