aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/crypto/iota-cli-app/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/crypto/iota-cli-app/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/crypto/iota-cli-app/default.nix')
-rw-r--r--flakes/mypackages/pkgs/crypto/iota-cli-app/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/crypto/iota-cli-app/default.nix b/flakes/mypackages/pkgs/crypto/iota-cli-app/default.nix
new file mode 100644
index 0000000..e386489
--- /dev/null
+++ b/flakes/mypackages/pkgs/crypto/iota-cli-app/default.nix
@@ -0,0 +1,29 @@
1{ stdenv, mylibs, fetchFromGitHub, fetchurl, fetchgit, callPackage, nodePackages, nodejs-10_x }:
2let
3 nodeEnv = callPackage mylibs.nodeEnv { nodejs = nodejs-10_x; };
4 # built using node2nix -8 -l package-lock.json
5 # and changing "./." to "src"
6 packageEnv = import ./node-packages.nix {
7 src = stdenv.mkDerivation ({
8 pname = "iota-cli-app";
9 version = "d7e2e08-master";
10 src = fetchFromGitHub {
11 owner = "iotaledger";
12 repo = "cli-app";
13 rev = "d7e2e0856ae6bd34890fefb4245c07cd467a5032";
14 sha256 = "1n9kczsxdgjv8282nj2grlijvxipiskx0ndn169vz6v1l1hrwc8b";
15 fetchSubmodules = true;
16 };
17 phases = "installPhase";
18 installPhase = ''
19 cp -a $src $out
20 chmod u+w -R $out
21 cd $out
22 sed -i -e "s@host: 'http://localhost',@host: 'https://nodes.thetangle.org',@" index.js
23 sed -i -e "s@port: 14265@port: 443@" index.js
24 '';
25 });
26 inherit fetchurl fetchgit nodeEnv;
27 };
28in
29packageEnv.package