aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/commento
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/commento
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/commento')
-rw-r--r--flakes/mypackages/pkgs/commento/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/commento/default.nix b/flakes/mypackages/pkgs/commento/default.nix
new file mode 100644
index 0000000..6361583
--- /dev/null
+++ b/flakes/mypackages/pkgs/commento/default.nix
@@ -0,0 +1,20 @@
1{ stdenv, fetchurl, patchelfUnstable, autoPatchelfHook }:
2stdenv.mkDerivation rec {
3 pname = "commento";
4 version = "v1.8.0";
5 name = "${pname}-${version}";
6 src = fetchurl {
7 url = "https://dl.commento.io/release/${name}-linux-glibc-amd64.tar.gz";
8 sha256 = "1j88b16hdx3i8nsq56581cscij65slgbsa6yfj73ybbg1585axxs";
9 };
10 phases = [ "unpackPhase" "installPhase" "fixupPhase" ];
11 unpackPhase = ''
12 tar --one-top-level=${name} -xf "$src"
13 '';
14 installPhase = ''
15 cp -a ${name} $out
16 '';
17 postFixup = ''
18 ${patchelfUnstable}/bin/patchelf --set-interpreter "$(cat $NIX_CC/nix-support/dynamic-linker)" $out/commento
19 '';
20}