aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/pkgs/boinctui/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/pkgs/boinctui/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/pkgs/boinctui/default.nix')
-rw-r--r--flakes/mypackages/pkgs/boinctui/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flakes/mypackages/pkgs/boinctui/default.nix b/flakes/mypackages/pkgs/boinctui/default.nix
new file mode 100644
index 0000000..565840c
--- /dev/null
+++ b/flakes/mypackages/pkgs/boinctui/default.nix
@@ -0,0 +1,21 @@
1{ stdenv, fetchurl, expat, openssl, autoconf269, ncurses }:
2stdenv.mkDerivation rec {
3 name = "boinctui-${version}";
4 version = "2.6.0";
5 src = fetchurl {
6 url = "http://sourceforge.net/projects/boinctui/files/boinctui_${version}.tar.gz";
7 sha256 = "1c6hc4x28z8hjncxcwxhb0r3980f72i6480569a0hd9y7vcgf3d0";
8 };
9
10 configureFlags = [ "--without-gnutls" ];
11 preConfigure = ''
12 autoconf
13 '';
14
15 makeFlags = [ "DESTDIR=$(out)" ];
16 preBuild = ''
17 sed -i -e 's/"HOME"/"XDG_CONFIG_HOME"/' src/cfg.cpp
18 sed -i -e 's@\.boinctui\.cfg@boinctui/boinctui.cfg@' src/mainprog.cpp
19 '';
20 buildInputs = [ expat openssl autoconf269 ncurses ];
21}