diff options
author | Ismaël Bouya <ismael.bouya@normalesup.org> | 2023-10-04 01:35:06 +0200 |
---|---|---|
committer | Ismaël Bouya <ismael.bouya@normalesup.org> | 2023-10-04 02:11:48 +0200 |
commit | 1a64deeb894dc95e2645a75771732c6cc53a79ad (patch) | |
tree | 1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/overlays/taskwarrior | |
parent | fa25ffd4583cc362075cd5e1b4130f33306103f0 (diff) | |
download | Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip |
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them
contained personnal information about users. All thos changes got
stashed into a single commit (history is kept in a different place) and
private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/overlays/taskwarrior')
-rw-r--r-- | flakes/mypackages/overlays/taskwarrior/TW-1778_patch.diff | 12 | ||||
-rw-r--r-- | flakes/mypackages/overlays/taskwarrior/default.nix | 16 |
2 files changed, 28 insertions, 0 deletions
diff --git a/flakes/mypackages/overlays/taskwarrior/TW-1778_patch.diff b/flakes/mypackages/overlays/taskwarrior/TW-1778_patch.diff new file mode 100644 index 0000000..6d7e376 --- /dev/null +++ b/flakes/mypackages/overlays/taskwarrior/TW-1778_patch.diff | |||
@@ -0,0 +1,12 @@ | |||
1 | --- a/src/text.cpp 2016-02-24 23:18:11.000000000 +0100 | ||
2 | +++ b/src/text.cpp 2020-02-26 18:53:15.869331031 +0100 | ||
3 | @@ -248,7 +248,7 @@ | ||
4 | // Premature EOL. | ||
5 | if (character == '\n') | ||
6 | { | ||
7 | - line = text.substr (offset, line_length); | ||
8 | + line = text.substr (offset, prior_cursor-offset); | ||
9 | offset = cursor; | ||
10 | return true; | ||
11 | } | ||
12 | |||
diff --git a/flakes/mypackages/overlays/taskwarrior/default.nix b/flakes/mypackages/overlays/taskwarrior/default.nix new file mode 100644 index 0000000..9ca52b8 --- /dev/null +++ b/flakes/mypackages/overlays/taskwarrior/default.nix | |||
@@ -0,0 +1,16 @@ | |||
1 | self: super: | ||
2 | { | ||
3 | taskwarrior = super.taskwarrior.overrideAttrs (old: { | ||
4 | patches = old.patches or [] ++ [ | ||
5 | ./TW-1778_patch.diff | ||
6 | ]; | ||
7 | postInstall = ''${old.postInstall} | ||
8 | mkdir -p "$out/share/vim/vimfiles/ftdetect" | ||
9 | mkdir -p "$out/share/vim/vimfiles/syntax" | ||
10 | ln -s "../../../../share/doc/task/scripts/vim/ftdetect/task.vim" "$out/share/vim/vimfiles/ftdetect/" | ||
11 | ln -s "../../../../share/doc/task/scripts/vim/syntax/taskrc.vim" "$out/share/vim/vimfiles/syntax/" | ||
12 | ln -s "../../../../share/doc/task/scripts/vim/syntax/taskdata.vim" "$out/share/vim/vimfiles/syntax/" | ||
13 | ln -s "../../../../share/doc/task/scripts/vim/syntax/taskedit.vim" "$out/share/vim/vimfiles/syntax/" | ||
14 | ''; | ||
15 | }); | ||
16 | } | ||