aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/overlays/kanboard
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/overlays/kanboard
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/overlays/kanboard')
-rw-r--r--flakes/mypackages/overlays/kanboard/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flakes/mypackages/overlays/kanboard/default.nix b/flakes/mypackages/overlays/kanboard/default.nix
new file mode 100644
index 0000000..2a0d41b
--- /dev/null
+++ b/flakes/mypackages/overlays/kanboard/default.nix
@@ -0,0 +1,19 @@
1self: super: {
2 kanboard = self.stdenv.mkDerivation rec {
3 name = "kanboard-${version}";
4 version = "1.2.21";
5 src = self.fetchFromGitHub {
6 owner = "kanboard";
7 repo = "kanboard";
8 rev = "ee18479b7e019e6415d7b095da629932ee1b3fd5";
9 sha256 = "00pnpq5qgxpb2f9la58ycvx5kx3pmcvpssh6lwgpcdk04yciw8nh";
10 };
11
12 dontBuild = true;
13
14 installPhase = ''
15 cp -a . $out
16 mv $out/data $out/dataold
17 '';
18 };
19}