aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/overlays/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/overlays/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/overlays/default.nix')
-rw-r--r--flakes/mypackages/overlays/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/flakes/mypackages/overlays/default.nix b/flakes/mypackages/overlays/default.nix
new file mode 100644
index 0000000..e91d6a1
--- /dev/null
+++ b/flakes/mypackages/overlays/default.nix
@@ -0,0 +1,25 @@
1{ sources, mylibs }:
2{
3 mylibs = self: super: { inherit mylibs; };
4 mypkgs = final: prev: import ../pkgs/default.nix { pkgs = final; inherit mylibs sources; };
5
6 bitlbee = import ./bitlbee;
7 bitlbee-discord = import ./bitlbee-discord;
8 gitweb = import ./gitweb;
9 gitolite = import ./gitolite;
10 goaccess = import ./goaccess;
11 kanboard = import ./kanboard;
12 mysql = import ./databases/mysql;
13 postfix = import ./postfix;
14 postgresql = import ./databases/postgresql;
15 ympd = import ./ympd;
16 morph = import ./morph;
17 cron = self: super: {
18 cron = super.cron.overrideAttrs(old: {
19 # Allow "+" char in MAILTO
20 patchPhase = ''
21 sed -i -e "/static const char safe_delim/s/@/@+/" do_command.c
22 '';
23 });
24 };
25}