aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/lib/flake-parts-lib.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/lib/flake-parts-lib.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/lib/flake-parts-lib.nix')
-rw-r--r--flakes/mypackages/lib/flake-parts-lib.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/flakes/mypackages/lib/flake-parts-lib.nix b/flakes/mypackages/lib/flake-parts-lib.nix
new file mode 100644
index 0000000..271a4cf
--- /dev/null
+++ b/flakes/mypackages/lib/flake-parts-lib.nix
@@ -0,0 +1,10 @@
1i@{ name, type }:
2{ lib, flake-parts-lib, ... }:
3flake-parts-lib.mkTransposedPerSystemModule {
4 inherit name;
5 option = lib.mkOption {
6 type = lib.types.lazyAttrsOf lib.types."${type}";
7 default = { };
8 };
9 file = import ./flake-parts-lib.nix i;
10}