aboutsummaryrefslogtreecommitdiff
path: root/flakes/mypackages/lib/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/mypackages/lib/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/mypackages/lib/default.nix')
-rw-r--r--flakes/mypackages/lib/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/flakes/mypackages/lib/default.nix b/flakes/mypackages/lib/default.nix
new file mode 100644
index 0000000..972ace0
--- /dev/null
+++ b/flakes/mypackages/lib/default.nix
@@ -0,0 +1,37 @@
1{
2 flakePartsAddPerSystem = import ./flake-parts-lib.nix;
3 nodeEnv = import ./node-env.nix;
4 postfixScript = pkgs: name: script: pkgs.writeScript name ''
5 #! ${pkgs.stdenv.shell}
6 mail=$(${pkgs.coreutils}/bin/cat -)
7 output=$(echo "$mail" | ${script} 2>&1)
8 ret=$?
9
10 if [ "$ret" != "0" ]; then
11 echo "$mail" \
12 | ${pkgs.procmail}/bin/formail -i "X-Return-Code: $ret" \
13 | /run/wrappers/bin/sendmail -i scripts_error+${name}@mail.immae.eu
14
15 messageId=$(echo "$mail" | ${pkgs.procmail}/bin/formail -x "Message-Id:")
16 repeat=$(echo "$mail" | ${pkgs.procmail}/bin/formail -X "From:" -X "Received:")
17
18 ${pkgs.coreutils}/bin/cat <<EOF | /run/wrappers/bin/sendmail -i scripts_error+${name}@mail.immae.eu
19 $repeat
20 To: scripts_error+${name}@mail.immae.eu
21 Subject: Log from script error
22 Content-Type: text/plain; charset="UTF-8"
23 Content-Transfer-Encoding: 8bit
24 References:$messageId
25 MIME-Version: 1.0
26 X-Return-Code: $ret
27
28 Error code: $ret
29 Output of message:
30 --------------
31 $output
32 --------------
33 EOF
34 fi
35 '';
36
37}