aboutsummaryrefslogtreecommitdiff
path: root/flakes/grocy/flake.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/grocy/flake.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/grocy/flake.nix')
-rw-r--r--flakes/grocy/flake.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/flakes/grocy/flake.nix b/flakes/grocy/flake.nix
new file mode 100644
index 0000000..a08852f
--- /dev/null
+++ b/flakes/grocy/flake.nix
@@ -0,0 +1,35 @@
1{
2 description = "ERP beyond your fridge - grocy is a web-based self-hosted groceries & household management solution for your home";
3 inputs.flake-utils.url = "github:numtide/flake-utils";
4 inputs.nixpkgs = {
5 url = "github:NixOS/nixpkgs/840c782d507d60aaa49aa9e3f6d0b0e780912742";
6 flake = false;
7 };
8 inputs.grocy = {
9 url = "github:grocy/grocy/d7738aa1ec330c81f11e4976681df0299d4ed35a";
10 flake = false;
11 };
12 inputs.mypackages.url = "path:../mypackages";
13 outputs = { self, nixpkgs, grocy, flake-utils, mypackages }: flake-utils.lib.eachSystem ["x86_64-linux"] (system:
14 let
15 pkgs = import nixpkgs { inherit system; overlays = []; };
16 composerEnv = mypackages.lib."${system}".composerEnv;
17 version = (builtins.fromJSON (builtins.readFile ./flake.lock)).nodes.grocy.original.ref;
18 inherit (pkgs) callPackage;
19 in rec {
20 packages.grocy = callPackage ./. { inherit composerEnv; src = grocy // { inherit version; }; };
21 defaultPackage = packages.grocy;
22 legacyPackages.grocy = packages.grocy;
23 checks = {
24 build = defaultPackage;
25 };
26 }
27 ) // rec {
28 overlays = {
29 grocy = final: prev: {
30 grocy = self.defaultPackage."${final.system}";
31 };
32 };
33 overlay = overlays.grocy;
34 };
35}