aboutsummaryrefslogtreecommitdiff
path: root/flakes/etherpad-lite/modules/ep_embedmedia/node-packages.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/etherpad-lite/modules/ep_embedmedia/node-packages.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/etherpad-lite/modules/ep_embedmedia/node-packages.nix')
-rw-r--r--flakes/etherpad-lite/modules/ep_embedmedia/node-packages.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/flakes/etherpad-lite/modules/ep_embedmedia/node-packages.nix b/flakes/etherpad-lite/modules/ep_embedmedia/node-packages.nix
new file mode 100644
index 0000000..80ba484
--- /dev/null
+++ b/flakes/etherpad-lite/modules/ep_embedmedia/node-packages.nix
@@ -0,0 +1,29 @@
1# This file has been generated by node2nix 1.8.0. Do not edit!
2
3{nodeEnv, fetchurl, fetchgit, globalBuildInputs ? []}:
4
5let
6 sources = {};
7in
8{
9 ep_embedmedia = nodeEnv.buildNodePackage {
10 name = "ep_embedmedia";
11 packageName = "ep_embedmedia";
12 version = "0.0.4";
13 src = fetchurl {
14 url = "https://registry.npmjs.org/ep_embedmedia/-/ep_embedmedia-0.0.4.tgz";
15 sha1 = "b24bf0fe9702d21aa73079890e93183efc6a0975";
16 };
17 buildInputs = globalBuildInputs;
18 preRebuild = ''
19 patch -p1 < ${./fix.patch}
20 '';
21 meta = {
22 description = "Embed media (youtube, vimeo etc)";
23 homepage = https://github.com/JohnMcLear/ep_embedmedia;
24 };
25 production = true;
26 bypassCache = true;
27 reconstructLock = true;
28 };
29}