aboutsummaryrefslogtreecommitdiff
path: root/flakes/copanier/pyproject.toml
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/copanier/pyproject.toml
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/copanier/pyproject.toml')
-rw-r--r--flakes/copanier/pyproject.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/flakes/copanier/pyproject.toml b/flakes/copanier/pyproject.toml
new file mode 100644
index 0000000..ba487ae
--- /dev/null
+++ b/flakes/copanier/pyproject.toml
@@ -0,0 +1,40 @@
1[tool.poetry]
2name = "copanier"
3version = "0.0.4"
4description = ""
5authors = ["Your Name <you@example.com>"]
6
7[tool.poetry.dependencies]
8python = "^3.7"
9Jinja2 = "2.11.2"
10openpyxl = "3.0.5"
11PyJWT = "1.7.1"
12PyYAML = "5.3.1"
13roll = "0.13.0"
14ujson = "3.2.0"
15minicli = "0.5.0"
16python-slugify = "4.0.1"
17debts = "0.5"
18emails = "0.6"
19Weasyprint = "51"
20
21#[tool.poetry.dev-dependencies]
22#hupper = "1.10.2"
23#minicli = "0.5.0"
24#usine = "0.2.3"
25#
26#[tool.poetry.group.test.dependencies]
27#pyquery = "1.4.1"
28#pytest = "6.0.2"
29#pytest-asyncio = "0.14.0"
30#
31#[tool.poetry.group.prod.dependencies]
32#gunicorn = "20.0.4"
33#uvloop = "0.14.0"
34
35[tool.poetry.scripts]
36copanier = 'copanier:main'
37
38[build-system]
39requires = ["poetry-core>=1.0.0"]
40build-backend = "poetry.core.masonry.api"