aboutsummaryrefslogtreecommitdiff
path: root/flakes/copanier/flake.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/copanier/flake.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/copanier/flake.nix')
-rw-r--r--flakes/copanier/flake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/flakes/copanier/flake.nix b/flakes/copanier/flake.nix
new file mode 100644
index 0000000..74e6829
--- /dev/null
+++ b/flakes/copanier/flake.nix
@@ -0,0 +1,28 @@
1{
2 description = "Copanier";
3
4 inputs.flake-utils.url = "github:numtide/flake-utils";
5 inputs.nixpkgs.url = "github:NixOS/nixpkgs";
6 inputs.copanier = {
7 url = "github:spiral-project/copanier";
8 flake = false;
9 };
10
11 outputs = { self, copanier, flake-utils, nixpkgs }: flake-utils.lib.eachDefaultSystem (system:
12 let
13 pkgs = import nixpkgs { inherit system; overlays = []; };
14 in rec {
15 packages.copanier = pkgs.callPackage ./. { src = copanier; };
16 defaultPackage = packages.copanier;
17 legacyPackages.copanier = packages.copanier;
18 apps.copanier = flake-utils.lib.mkApp { drv = packages.copanier; };
19 defaultApp = apps.copanier;
20 }) // rec {
21 overlays = {
22 copanier = final: prev: {
23 copanier = self.defaultPackage."${final.system}";
24 };
25 };
26 overlay = overlays.copanier;
27 };
28 }