aboutsummaryrefslogtreecommitdiff
path: root/flakes/copanier/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 01:35:06 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2023-10-04 02:11:48 +0200
commit1a64deeb894dc95e2645a75771732c6cc53a79ad (patch)
tree1b9df4838f894577a09b9b260151756272efeb53 /flakes/copanier/default.nix
parentfa25ffd4583cc362075cd5e1b4130f33306103f0 (diff)
downloadNix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.gz
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.tar.zst
Nix-1a64deeb894dc95e2645a75771732c6cc53a79ad.zip
Squash changes containing private information
There were a lot of changes since the previous commit, but a lot of them contained personnal information about users. All thos changes got stashed into a single commit (history is kept in a different place) and private information was moved in a separate private repository
Diffstat (limited to 'flakes/copanier/default.nix')
-rw-r--r--flakes/copanier/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/flakes/copanier/default.nix b/flakes/copanier/default.nix
new file mode 100644
index 0000000..0486c0a
--- /dev/null
+++ b/flakes/copanier/default.nix
@@ -0,0 +1,30 @@
1{ src, glibcLocales, poetry2nix, fetchFromGitHub, python37, fetchpatch }:
2let
3 poetryApp = poetry2nix.mkPoetryApplication rec {
4 inherit src;
5 patches = [ ./fix_reduce.patch ];
6 overrides = poetry2nix.overrides.withDefaults (self: super: {
7 weasyprint = super.weasyprint.overridePythonAttrs (old: {
8 patches = let
9 p0 = (fetchpatch {
10 url = "https://github.com/Kozea/WeasyPrint/commit/47043a1fd7e50a892b9836466f521df85d597c44.patch";
11 sha256 = "18lmz6whjqxdpv4fdmg5vcpk2acdl99kfmp14badpw1jmffw7zl2";
12 postFetch = ''
13 sed -i -e "s/font_filename/filename/" $out
14 '';
15 });
16 p1 = (builtins.elemAt old.patches 1).overrideAttrs(old: {
17 postInstall = ''
18 sed -i -e "s/so.0/so/" $out
19 '';
20 });
21 in [ p0 p1 ];
22 });
23 });
24 pyproject = ./pyproject.toml;
25 poetrylock = ./poetry.lock;
26 python = python37;
27 locales = "${glibcLocales}/lib/locale/locale-archive";
28 };
29in
30 poetryApp