aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-02 12:01:33 +0200
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-05-02 12:34:00 +0200
commitfdf6f74d3221e3dad853898f296149baea0aa476 (patch)
tree9fcd0db87425e2f533354a431d2fa81bd55cbe36 /default.nix
parent6e2dc958bc8c5aac4871d2a618741fa4628ed126 (diff)
downloadNix-fdf6f74d3221e3dad853898f296149baea0aa476.tar.gz
Nix-fdf6f74d3221e3dad853898f296149baea0aa476.tar.zst
Nix-fdf6f74d3221e3dad853898f296149baea0aa476.zip
Refactor configuration and overlays
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix122
1 files changed, 10 insertions, 112 deletions
diff --git a/default.nix b/default.nix
index 9c548a0..e092c33 100644
--- a/default.nix
+++ b/default.nix
@@ -1,112 +1,10 @@
1with import <nixpkgs> { overlays = builtins.attrValues (import ./overlays); }; 1{ pkgs ? import <nixpkgs> {} }:
2 # https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh 2let
3 # https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks 3 pkgs_ = pkgs;
4 { # files in overlays/mypkgs.nix 4 mypkgs = import ./pkgs { pkgs = pkgs_; };
5 inherit boinctui; 5in
6 inherit cnagios; 6{
7 inherit duply; 7 lib = import ./libs.nix { pkgs = pkgs_; };
8 inherit flrn; 8 overlays = import ./overlays;
9 inherit genius; 9 pkgs = mypkgs;
10 inherit mtop; 10} // mypkgs
11 inherit muttprint;
12 inherit mutt-ics;
13 inherit nagios-cli;
14 #inherit nagnu;
15 inherit note;
16 inherit notmuch-python2;
17 inherit notmuch-python3;
18 inherit notmuch-vim;
19 inherit pg_activity;
20 inherit pgloader;
21 inherit telegram-cli;
22 inherit telegram-history-dump;
23 inherit telegramircd;
24 inherit terminal-velocity;
25 inherit tiv;
26 inherit unicodeDoc;
27
28 inherit cardano;
29 inherit iota-cli-app;
30 inherit sia;
31 } // { # overlays
32 inherit weboob;
33 inherit taskwarrior;
34 inherit slrn;
35 inherit sc-im;
36 inherit lesspipe;
37 inherit neomutt;
38 inherit weechat;
39 inherit goaccess;
40 inherit profanity;
41 inherit nixops;
42 inherit dwm;
43 inherit vit;
44 inherit pass;
45 inherit elinks;
46 inherit pelican;
47 inherit ldapvi;
48 inherit (mylibs.yarn2nixPackage) yarn2nix;
49 } // {
50 inherit nix-prefetch-scripts;
51 inherit nix-generate-from-cpan;
52 inherit timewarrior;
53 inherit pal;
54 inherit pdftk;
55 inherit googler;
56 inherit jrnl;
57 inherit apg pwgen;
58 inherit newsboat;
59 inherit vcsh;
60 inherit xmr-stak;
61 inherit urlwatch;
62 inherit ranger;
63 inherit irssi;
64 inherit abook khard khal;
65 inherit graphicsmagick;
66 inherit youtube-dl;
67 inherit ncmpc ncmpcpp;
68 inherit cadaver;
69 inherit mairix notmuch;
70 inherit ctags;
71 inherit s3cmd;
72 inherit solc; # solidity
73 inherit rtorrent;
74 inherit strace;
75 inherit vdirsyncer;
76 inherit w3m lynx links;
77 inherit gitRepo;
78 inherit valgrind;
79 inherit iotop iperf;
80 inherit keybase;
81 inherit bogofilter;
82 inherit mtr;
83 inherit urlview;
84 inherit rr;
85 inherit nix-zsh-completions;
86 inherit browsh;
87 inherit monero;
88 inherit nextcloud-client;
89 inherit feh imagemagick;
90 inherit lftp;
91 stgit = gitAndTools.stgit;
92 inherit bundix;
93 bower2nix = nodePackages.bower2nix;
94 inherit firefox;
95 inherit jq;
96 inherit lzo unzip bzip2 p7zip xz;
97 # unrar is unfree
98 inherit tig;
99 inherit emacs26-nox;
100 inherit highlight sourceHighlight;
101 pygmentize = python3Packages.pygments;
102 inherit iftop htop;
103 inherit fetchmail;
104 inherit bc;
105 inherit cpulimit;
106 inherit dmenu st;
107 inherit poppler_utils;
108 inherit tmux;
109 inherit netcat-gnu;
110 inherit ledger;
111 inherit ffmpeg libxslt;
112 }