aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-03-10 00:30:24 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-03-10 00:30:24 +0100
commitfcf18de4a44fcc496837fbb6eedcc01e5f6eb680 (patch)
tree8f65cdc607c7a41e5789eb3bd04c80ef732f6865 /default.nix
parentc92933bfa2d95533ea5c8650ff4d40b6621e600f (diff)
downloadNix-fcf18de4a44fcc496837fbb6eedcc01e5f6eb680.tar.gz
Nix-fcf18de4a44fcc496837fbb6eedcc01e5f6eb680.tar.zst
Nix-fcf18de4a44fcc496837fbb6eedcc01e5f6eb680.zip
Upgrade packages to 19.03
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix71
1 files changed, 34 insertions, 37 deletions
diff --git a/default.nix b/default.nix
index c8d8c8b..ad9bca7 100644
--- a/default.nix
+++ b/default.nix
@@ -1,5 +1,5 @@
1with import ./libs.nix; 1with import ./libs.nix;
2with import <nixpkgs> {}; 2with import <immaeNixpkgsNext> {};
3let 3let
4 mypkgs = {}; 4 mypkgs = {};
5 5
@@ -26,11 +26,13 @@ let
26 } 26 }
27 ); 27 );
28 28
29 mypkgs.weboob = pythonPackages.weboob.overrideAttrs (old: rec { 29 mypkgs.weboob = (pythonPackages.weboob.overridePythonAttrs {
30 postInstall = ''${old.postInstall or ""} 30 setupPyBuildFlags = [ "--no-qt" "--xdg" ];
31 mkdir -p $out/share/bash-completion/completions/ 31 }).overrideAttrs (old: rec {
32 cp tools/weboob_bash_completion $out/share/bash-completion/completions/weboob 32 postInstall = ''${old.postInstall or ""}
33 ''; 33 mkdir -p $out/share/bash-completion/completions/
34 cp tools/weboob_bash_completion $out/share/bash-completion/completions/weboob
35 '';
34 }); 36 });
35 37
36 mypkgs.slrn = slrn.overrideAttrs (old: rec { 38 mypkgs.slrn = slrn.overrideAttrs (old: rec {
@@ -61,7 +63,17 @@ let
61 configureFlags = old.configureFlags ++ [ "--enable-plugins" ]; 63 configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
62 }); 64 });
63 65
64 mypkgs.weechat = nixpkgs_unstable.weechat.override { 66 mypkgs.weechat = (wrapWeechat (
67 weechat-unwrapped.overrideAttrs (old: rec {
68 version = "2.3";
69 name = "weechat-${version}";
70 src = fetchurl {
71 url = "https://weechat.org/files/src/weechat-${version}.tar.bz2";
72 sha256 = "0mi4pfnyny0vqc35r0scn6yy21y790a5iwq8ms7kch7b7z11jn9w";
73 };
74 patches = [];
75 })
76 ) {}).override {
65 configure = { availablePlugins, ... }: { 77 configure = { availablePlugins, ... }: {
66 plugins = with availablePlugins; [ 78 plugins = with availablePlugins; [
67 (python.withPackages (ps: with ps; [websocket_client emoji])) 79 (python.withPackages (ps: with ps; [websocket_client emoji]))
@@ -89,18 +101,19 @@ let
89 }; 101 };
90 }; 102 };
91 103
92 mypkgs.terminal-velocity = with python2Packages; buildPythonApplication rec { 104 mypkgs.terminal-velocity = with python3Packages; buildPythonApplication rec {
93 pname = "terminal-velocity-git"; 105 pname = "terminal-velocity-git";
94 version = "0.2.0"; 106 version = "0.2.0";
95 107
96 patches = [ 108 patches = [
109 ./patches/terminal_velocity_sort_found_notes.patch
110 ./patches/terminal_velocity_python3_support.patch
97 # FIXME: update this patch when version changes 111 # FIXME: update this patch when version changes
98 ./patches/terminal_velocity_fix_build.patch 112 ./patches/terminal_velocity_fix_build.patch
99 ./patches/terminal_velocity_sort_found_notes.patch
100 ]; 113 ];
101 114
102 propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ]; 115 propagatedBuildInputs = [ chardet urwid (sh.overridePythonAttrs { doCheck = false; }) pyyaml ];
103 buildInputs = [ m2r restructuredtext_lint pygments ]; 116 buildInputs = [ m2r (restructuredtext_lint.overridePythonAttrs { doCheck = false; }) pygments ];
104 117
105 postInstall = '' 118 postInstall = ''
106 rm $out/bin/terminal_velocity 119 rm $out/bin/terminal_velocity
@@ -456,9 +469,9 @@ let
456 469
457 mypkgs.notmuch-vim = stdenv.mkDerivation rec { 470 mypkgs.notmuch-vim = stdenv.mkDerivation rec {
458 name = "notmuch-vim-${version}"; 471 name = "notmuch-vim-${version}";
459 version = nixpkgs_unstable.notmuch.version; 472 version = notmuch.version;
460 outputs = [ "out" ]; 473 outputs = [ "out" ];
461 src = nixpkgs_unstable.notmuch.src; 474 src = notmuch.src;
462 phases = [ "unpackPhase" "installPhase" ]; 475 phases = [ "unpackPhase" "installPhase" ];
463 installPhase = '' 476 installPhase = ''
464 make -C vim DESTDIR=$out prefix="/share/vim/vimfiles" install 477 make -C vim DESTDIR=$out prefix="/share/vim/vimfiles" install
@@ -467,10 +480,10 @@ let
467 480
468 mypkgs.notmuch-python2 = stdenv.mkDerivation rec { 481 mypkgs.notmuch-python2 = stdenv.mkDerivation rec {
469 name = "notmuch-python2-${version}"; 482 name = "notmuch-python2-${version}";
470 version = nixpkgs_unstable.notmuch.version; 483 version = notmuch.version;
471 outputs = [ "out" ]; 484 outputs = [ "out" ];
472 buildInputs = [ python2Packages.sphinx python2Packages.python ]; 485 buildInputs = [ python2Packages.sphinx python2Packages.python ];
473 src = nixpkgs_unstable.notmuch.src; 486 src = notmuch.src;
474 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ]; 487 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
475 buildPhase = '' 488 buildPhase = ''
476 cd bindings/python 489 cd bindings/python
@@ -483,10 +496,10 @@ let
483 496
484 mypkgs.notmuch-python3 = stdenv.mkDerivation rec { 497 mypkgs.notmuch-python3 = stdenv.mkDerivation rec {
485 name = "notmuch-python3-${version}"; 498 name = "notmuch-python3-${version}";
486 version = nixpkgs_unstable.notmuch.version; 499 version = notmuch.version;
487 outputs = [ "out" ]; 500 outputs = [ "out" ];
488 buildInputs = [ nixpkgs_unstable.python3Packages.sphinx nixpkgs_unstable.python3Packages.python ]; 501 buildInputs = [ python3Packages.sphinx python3Packages.python ];
489 src = nixpkgs_unstable.notmuch.src; 502 src = notmuch.src;
490 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ]; 503 phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
491 buildPhase = '' 504 buildPhase = ''
492 cd bindings/python 505 cd bindings/python
@@ -581,24 +594,8 @@ in
581 inherit feh imagemagick; 594 inherit feh imagemagick;
582 inherit lftp; 595 inherit lftp;
583 stgit = gitAndTools.stgit; 596 stgit = gitAndTools.stgit;
584 # todo: lx* ?, unrar, unzip, zeromq?
585 #inherit nextcloud-client;
586 #inherit nixos;
587 } // (with nixpkgs_unstable; {
588 inherit googler;
589 inherit khal;
590 inherit newsboat;
591 inherit xmr-stak;
592 inherit urlwatch;
593 inherit graphicsmagick;
594 inherit ncmpc;
595 inherit solc;
596 inherit w3m lynx links;
597 inherit valgrind;
598 inherit ranger;
599 inherit strace;
600 inherit notmuch notmuch-mutt;
601 stgit = gitAndTools.stgit;
602 inherit bundix; 597 inherit bundix;
603 bower2nix = nodePackages.bower2nix; 598 bower2nix = nodePackages.bower2nix;
604 }) 599 # todo: unrar, unzip
600 #inherit nixos;
601 }