aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-01-05 18:35:29 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-01-05 18:35:29 +0100
commitc7f50486428f67b91dea675704288134f835674c (patch)
tree386acd8863ac76ecc8c6dfa024cbe4460d74ac65 /default.nix
parentc5aaa64a9b1b389f10e2885fc4106c2b7926109d (diff)
downloadNix-c7f50486428f67b91dea675704288134f835674c.tar.gz
Nix-c7f50486428f67b91dea675704288134f835674c.tar.zst
Nix-c7f50486428f67b91dea675704288134f835674c.zip
Replace unstable with stable in environment
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix27
1 files changed, 20 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index a76cf7a..4e50c59 100644
--- a/default.nix
+++ b/default.nix
@@ -1,7 +1,6 @@
1with import ./libs.nix; 1with import ./libs.nix;
2with nixpkgs_unstable; 2with import <nixpkgs> {};
3let 3let
4 stable_nixpkgs = import <nixpkgs> {};
5 mypkgs = {}; 4 mypkgs = {};
6 postHook = '' 5 postHook = ''
7 header() { 6 header() {
@@ -76,7 +75,7 @@ let
76 configureFlags = old.configureFlags ++ [ "--enable-plugins" ]; 75 configureFlags = old.configureFlags ++ [ "--enable-plugins" ];
77 }); 76 });
78 77
79 mypkgs.weechat = weechat.override { 78 mypkgs.weechat = nixpkgs_unstable.weechat.override {
80 configure = { availablePlugins, ... }: { 79 configure = { availablePlugins, ... }: {
81 plugins = with availablePlugins; [ 80 plugins = with availablePlugins; [
82 (python.withPackages (ps: with ps; [websocket_client emoji])) 81 (python.withPackages (ps: with ps; [websocket_client emoji]))
@@ -93,7 +92,7 @@ let
93 sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq"; 92 sha256 = "1h645rnb5vpms48fcyzvp7cwwcbf9k5xq49w2bpniyzzgk2brjrq";
94 }; 93 };
95 outputs = ["out" "man"]; 94 outputs = ["out" "man"];
96 propragatedBuildInputs = [ perlPackages.YAML ]; 95 propagatedBuildInputs = [ perlPackages.YAML ];
97 meta = with stdenv.lib; { 96 meta = with stdenv.lib; {
98 description = "A perl script for maintaining notes"; 97 description = "A perl script for maintaining notes";
99 homepage = http://www.daemon.de/NOTE; 98 homepage = http://www.daemon.de/NOTE;
@@ -113,7 +112,7 @@ let
113 ./patches/terminal_velocity_sort_found_notes.patch 112 ./patches/terminal_velocity_sort_found_notes.patch
114 ]; 113 ];
115 114
116 propagatedBuildInputs = [ chardet urwid sh pyyaml ]; 115 propagatedBuildInputs = [ chardet urwid nixpkgs_unstable.python2Packages.sh pyyaml ];
117 buildInputs = [ m2r restructuredtext_lint pygments ]; 116 buildInputs = [ m2r restructuredtext_lint pygments ];
118 117
119 src = fetchPypi { 118 src = fetchPypi {
@@ -270,7 +269,6 @@ in
270 inherit timewarrior; 269 inherit timewarrior;
271 inherit sc-im; 270 inherit sc-im;
272 inherit pal; 271 inherit pal;
273 inherit duplicity duply;
274 inherit pdftk; 272 inherit pdftk;
275 inherit googler; 273 inherit googler;
276 inherit jrnl; 274 inherit jrnl;
@@ -306,4 +304,19 @@ in
306 # todo: lx* ?, unrar, unzip, zeromq? 304 # todo: lx* ?, unrar, unzip, zeromq?
307 #inherit nextcloud-client; 305 #inherit nextcloud-client;
308 #inherit nixos; 306 #inherit nixos;
309 } 307 } // (with nixpkgs_unstable; {
308 inherit googler;
309 inherit khal;
310 inherit newsboat;
311 inherit xmr-stak;
312 inherit urlwatch;
313 inherit graphicsmagick;
314 inherit ncmpc;
315 inherit solc;
316 inherit w3m lynx links;
317 inherit valgrind;
318 inherit ranger;
319 inherit strace;
320 inherit notmuch;
321 stgit = gitAndTools.stgit;
322 })