aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-02-16 12:49:17 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-02-16 12:49:17 +0100
commita556c4b01a536afd90042dad95e7cc09f37d4056 (patch)
tree7cf071b676e9add3e9f4c736faaa2d66b578583e /default.nix
parentea9d3f4ba1cfcab0eeb9cb719fc8065d38c3bb53 (diff)
downloadNix-a556c4b01a536afd90042dad95e7cc09f37d4056.tar.gz
Nix-a556c4b01a536afd90042dad95e7cc09f37d4056.tar.zst
Nix-a556c4b01a536afd90042dad95e7cc09f37d4056.zip
Add postHook to colorize build outputs
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 0 insertions, 14 deletions
diff --git a/default.nix b/default.nix
index 538ffaa..5e8c4d3 100644
--- a/default.nix
+++ b/default.nix
@@ -2,20 +2,6 @@ with import ./libs.nix;
2with import <nixpkgs> {}; 2with import <nixpkgs> {};
3let 3let
4 mypkgs = {}; 4 mypkgs = {};
5 postHook = ''
6 header() {
7 echo -ne "\033[1;36m"
8 echo -n "$1"
9 echo -e "\033[0m"
10 }
11
12 echoCmd() {
13 printf "\033[1;34m%s:\033[0m" "$1"
14 shift
15 printf ' %q' "$@"
16 echo
17 }
18 '';
19 5
20 mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old: 6 mypkgs.ledger = (ledger.override { boost = boost166; }).overrideAttrs (_old:
21 fetchedGithub ./fetched/ledger.json // { 7 fetchedGithub ./fetched/ledger.json // {