aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorIsmaël Bouya <ismael.bouya@normalesup.org>2019-01-13 13:57:55 +0100
committerIsmaël Bouya <ismael.bouya@normalesup.org>2019-01-13 14:11:20 +0100
commit35a397cd22e6c8dd7dec471f09416441b64deee4 (patch)
treeba771babc0e3d5265080f2fe9f1463ab2dd9d555 /default.nix
parent108891744eaa7410e305871212d5b81c1b67a095 (diff)
downloadNix-35a397cd22e6c8dd7dec471f09416441b64deee4.tar.gz
Nix-35a397cd22e6c8dd7dec471f09416441b64deee4.tar.zst
Nix-35a397cd22e6c8dd7dec471f09416441b64deee4.zip
Add mastodon service
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/default.nix b/default.nix
index c277602..9e79550 100644
--- a/default.nix
+++ b/default.nix
@@ -252,25 +252,6 @@ let
252 buildInputs = old.buildInputs ++ [ tokyocabinet bzip2 ]; 252 buildInputs = old.buildInputs ++ [ tokyocabinet bzip2 ];
253 }); 253 });
254 254
255 mastodon = stdenv.mkDerivation (fetchedGithub ./fetched/mastodon.json // rec {
256 buildPhase = ''
257 export GIT_SSL_CAINFO=${cacert}/etc/ssl/certs/ca-bundle.crt
258 export SSL_CERT_FILE=${cacert}/etc/ssl/certs/ca-bundle.crt
259
260 bundle install --deployment --without development test
261 yarn install --pure-lockfile
262 '';
263 installPhase = ''
264 cp -a . $out
265 '';
266 propagatedBuildInputs = [
267 zlib icu libchardet git bundler yarn
268 protobuf protobufc libidn libpqxx nodejs
269 imagemagick ffmpeg libxml2 libxslt pkgconfig
270 autoconf bison libyaml readline ncurses libffi gdbm
271 jemalloc which postgresql python3 cacert
272 ];
273 });
274# https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh 255# https://github.com/NixOS/nixpkgs/blob/master/pkgs/stdenv/generic/setup.sh
275# https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks 256# https://github.com/NixOS/nixpkgs/blob/master/doc/languages-frameworks
276in 257in
@@ -311,7 +292,6 @@ in
311 inherit mtr; 292 inherit mtr;
312 inherit nixops; 293 inherit nixops;
313 stgit = gitAndTools.stgit; 294 stgit = gitAndTools.stgit;
314 #inherit mastodon;
315 # todo: lx* ?, unrar, unzip, zeromq? 295 # todo: lx* ?, unrar, unzip, zeromq?
316 #inherit nextcloud-client; 296 #inherit nextcloud-client;
317 #inherit nixos; 297 #inherit nixos;