aboutsummaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b206c21..9924c53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,14 +39,15 @@ prepare() {
39 -i config.mk 39 -i config.mk
40 sed '/@tic/d' -i Makefile 40 sed '/@tic/d' -i Makefile
41 for file in "${source[@]}"; do 41 for file in "${source[@]}"; do
42 if [[ "$file" != *.diff ]]; then 42 if [[ "$file" == "config.h" ]]; then
43 # add config.h if present in source array 43 # add config.h if present in source array
44 # Note: this supersedes the above sed to config.def.h 44 # Note: this supersedes the above sed to config.def.h
45 [[ "$file" == "config.h" ]] && cp "$SRCDEST/$file" . 45 cp "$SRCDEST/$file" .
46 continue 46 continue
47 elif [[ "$file" == *.diff ]]; then
48 # add all patches present in source array
49 patch -Np1 <"$SRCDEST/$file"
47 fi 50 fi
48 # add all patches present in source array
49 patch -Np1 <"$SRCDEST/$file"
50 done 51 done
51} 52}
52 53