diff options
author | mar77i <mar77i@mar77i.ch> | 2015-10-15 13:44:42 +0200 |
---|---|---|
committer | mar77i <mar77i@mar77i.ch> | 2015-10-15 13:44:42 +0200 |
commit | 05baa36be4daf4d131900915f21db125ce2ccbce (patch) | |
tree | dccef0afd63fda82333eef5b05ecba589d398338 /PKGBUILD | |
parent | 19096d1498a90a1dcce0fd39eaa74715bc0331c0 (diff) | |
download | AUR-05baa36be4daf4d131900915f21db125ce2ccbce.tar.gz AUR-05baa36be4daf4d131900915f21db125ce2ccbce.tar.zst AUR-05baa36be4daf4d131900915f21db125ce2ccbce.zip |
make applying of patches and inserting config.h more readable
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 9 |
1 files changed, 5 insertions, 4 deletions
@@ -39,14 +39,15 @@ prepare() { | |||
39 | -i config.mk | 39 | -i config.mk |
40 | sed '/@tic/d' -i Makefile | 40 | sed '/@tic/d' -i Makefile |
41 | for file in "${source[@]}"; do | 41 | for file in "${source[@]}"; do |
42 | if [[ "$file" != *.diff ]]; then | 42 | if [[ "$file" == "config.h" ]]; then |
43 | # add config.h if present in source array | 43 | # add config.h if present in source array |
44 | # Note: this supersedes the above sed to config.def.h | 44 | # Note: this supersedes the above sed to config.def.h |
45 | [[ "$file" == "config.h" ]] && cp "$SRCDEST/$file" . | 45 | cp "$SRCDEST/$file" . |
46 | continue | 46 | continue |
47 | elif [[ "$file" == *.diff ]]; then | ||
48 | # add all patches present in source array | ||
49 | patch -Np1 <"$SRCDEST/$file" | ||
47 | fi | 50 | fi |
48 | # add all patches present in source array | ||
49 | patch -Np1 <"$SRCDEST/$file" | ||
50 | done | 51 | done |
51 | } | 52 | } |
52 | 53 | ||