]> git.immae.eu Git - perso/Immae/Projets/Python/MusicSampler.git/blobdiff - music_sampler.spec
Add version number
[perso/Immae/Projets/Python/MusicSampler.git] / music_sampler.spec
index ef949f201fb8b6b30b397961b8e0b144145e007a..7a885fd5ac837da5b90142debaf6531057214610 100644 (file)
@@ -1,14 +1,21 @@
 # -*- mode: python -*-
+import os
 from kivy.tools.packaging.pyinstaller_hooks import  get_deps_minimal, hookspath, runtime_hooks
 
 excluded_and_hidden_modules = get_deps_minimal(video=None, camera=None, audio=None, clipboard=None, spelling=None)
 excluded_and_hidden_modules['hiddenimports'] += [ 'six', 'packaging', 'packaging.version', 'packaging.specifiers', 'packaging.requirements']
 
+commit_message = os.popen('git log -1 --format="%h  %ci"').read()
+pyinstaller_file = open(".pyinstaller_commit", "w")
+pyinstaller_file.write(commit_message)
+pyinstaller_file.close()
+
 a = Analysis(['music_sampler.py'],
              binaries=None,
              datas=[
               ('fonts/*', 'fonts'),
-              ('music_sampler.kv', '.')
+              ('music_sampler.kv', '.'),
+              ('.pyinstaller_commit', '.')
              ],
              hookspath=hookspath(),
              runtime_hooks=runtime_hooks(),