]> git.immae.eu Git - perso/Immae/Projets/Python/MusicSampler.git/blobdiff - music_sampler.spec
Use pip setup file
[perso/Immae/Projets/Python/MusicSampler.git] / music_sampler.spec
index 0d99dca2caefcc67238169feeb09ab7fdcf94b1a..791cd686ec7d02798c4dabe25d5c5c3b3f0d24d0 100644 (file)
@@ -5,7 +5,7 @@ from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal,\
 
 import importlib.machinery
 sysfont = importlib.machinery\
-        .SourceFileLoader('sysfont', os.getcwd() + '/helpers/sysfont.py') \
+        .SourceFileLoader('sysfont', os.getcwd() + '/music_sampler/sysfont.py') \
         .load_module()
 
 excluded_and_hidden_modules = get_deps_minimal(
@@ -28,11 +28,11 @@ pyinstaller_file.write(commit_message)
 pyinstaller_file.close()
 
 data = [
-  ('music_sampler.kv', '.'),
+  ('music_sampler/music_sampler.kv', '.'),
   ('.pyinstaller_commit', '.')
 ]
 
-a = Analysis(['music_sampler.py'],
+a = Analysis(['run.py'],
              binaries=None,
              datas=data,
              hookspath=hookspath(),