]> git.immae.eu Git - perso/Immae/Projets/Python/MusicSampler.git/blobdiff - music_sampler.spec
Add config
[perso/Immae/Projets/Python/MusicSampler.git] / music_sampler.spec
index 5549b767f957bf77f38eb89c7dd11edb6ba8a84f..844ac4b6a6b1e166a6d124f7352fa4483e8da593 100644 (file)
@@ -6,7 +6,7 @@ from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal,\
 
 import importlib.machinery
 sysfont = importlib.machinery\
-        .SourceFileLoader('sysfont', os.getcwd() + '/music_sampler/sysfont.py') \
+        .SourceFileLoader('sysfont', os.getcwd()+'/music_sampler/sysfont.py') \
         .load_module()
 
 excluded_and_hidden_modules = get_deps_minimal(
@@ -30,17 +30,23 @@ pyinstaller_file.close()
 
 data = [
   ('music_sampler/music_sampler.kv', '.'),
-  ('.pyinstaller_commit', '.')
+  ('.pyinstaller_commit', '.'),
+  ('music_sampler/locales', 'locales')
 ]
 
 a = Analysis(['run.py'],
-             binaries=None,
              datas=data,
              hookspath=hookspath(),
              runtime_hooks=runtime_hooks(),
              **excluded_and_hidden_modules)
 
-for fontname, style in [("Ubuntu", sysfont.STYLE_NORMAL), ("Ubuntu", sysfont.STYLE_BOLD), ("Symbola", sysfont.STYLE_NONE)]:
+fonts = [
+  ("Ubuntu", sysfont.STYLE_NORMAL),
+  ("Ubuntu", sysfont.STYLE_BOLD),
+  ("Symbola", sysfont.STYLE_NONE)
+]
+
+for fontname, style in fonts:
     font = sysfont.get_font(fontname, style=style)
     a.datas.append((
         'fonts/{}_{}.ttf'.format(fontname, style),