]> git.immae.eu Git - perso/Immae/Projets/Python/MusicSampler.git/blobdiff - music_sampler.spec
Add config
[perso/Immae/Projets/Python/MusicSampler.git] / music_sampler.spec
index 0d99dca2caefcc67238169feeb09ab7fdcf94b1a..844ac4b6a6b1e166a6d124f7352fa4483e8da593 100644 (file)
@@ -1,11 +1,12 @@
 # -*- mode: python -*-
 import os
+import setuptools_scm
 from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal,\
         hookspath, runtime_hooks
 
 import importlib.machinery
 sysfont = importlib.machinery\
-        .SourceFileLoader('sysfont', os.getcwd() + '/helpers/sysfont.py') \
+        .SourceFileLoader('sysfont', os.getcwd()+'/music_sampler/sysfont.py') \
         .load_module()
 
 excluded_and_hidden_modules = get_deps_minimal(
@@ -22,24 +23,30 @@ excluded_and_hidden_modules['hiddenimports'] += [
         'packaging.specifiers',
         'packaging.requirements' ]
 
-commit_message = os.popen('git log -1 --format="%h  %ci"').read()
+commit_message = setuptools_scm.get_version()
 pyinstaller_file = open(".pyinstaller_commit", "w")
 pyinstaller_file.write(commit_message)
 pyinstaller_file.close()
 
 data = [
-  ('music_sampler.kv', '.'),
-  ('.pyinstaller_commit', '.')
+  ('music_sampler/music_sampler.kv', '.'),
+  ('.pyinstaller_commit', '.'),
+  ('music_sampler/locales', 'locales')
 ]
 
-a = Analysis(['music_sampler.py'],
-             binaries=None,
+a = Analysis(['run.py'],
              datas=data,
              hookspath=hookspath(),
              runtime_hooks=runtime_hooks(),
              **excluded_and_hidden_modules)
 
-for fontname, style in [("Ubuntu", sysfont.STYLE_NORMAL), ("Ubuntu", sysfont.STYLE_BOLD), ("Symbola", sysfont.STYLE_NONE)]:
+fonts = [
+  ("Ubuntu", sysfont.STYLE_NORMAL),
+  ("Ubuntu", sysfont.STYLE_BOLD),
+  ("Symbola", sysfont.STYLE_NONE)
+]
+
+for fontname, style in fonts:
     font = sysfont.get_font(fontname, style=style)
     a.datas.append((
         'fonts/{}_{}.ttf'.format(fontname, style),