]> git.immae.eu Git - perso/Immae/Projets/Python/MusicSampler.git/blobdiff - music_sampler.spec
Use setuptools_scm to determinate project version
[perso/Immae/Projets/Python/MusicSampler.git] / music_sampler.spec
index 791cd686ec7d02798c4dabe25d5c5c3b3f0d24d0..5549b767f957bf77f38eb89c7dd11edb6ba8a84f 100644 (file)
@@ -1,5 +1,6 @@
 # -*- mode: python -*-
 import os
+import setuptools_scm
 from kivy.tools.packaging.pyinstaller_hooks import get_deps_minimal,\
         hookspath, runtime_hooks
 
@@ -22,7 +23,7 @@ excluded_and_hidden_modules['hiddenimports'] += [
         'packaging.specifiers',
         'packaging.requirements' ]
 
-commit_message = os.popen('git log -1 --format="%h  %ci"').read()
+commit_message = setuptools_scm.get_version()
 pyinstaller_file = open(".pyinstaller_commit", "w")
 pyinstaller_file.write(commit_message)
 pyinstaller_file.close()