]> git.immae.eu Git - perso/Immae/Config/Nix/NUR.git/blob - pkgs/telethon_sync/default.nix
5cbff95c2ff7f925f966513714fbaf435c70b836
[perso/Immae/Config/Nix/NUR.git] / pkgs / telethon_sync / default.nix
1 { lib, python3Packages }:
2 with python3Packages;
3 buildPythonPackage rec {
4 pname = "Telethon-sync";
5 version = "1.1.1";
6
7 src = builtins.fetchGit {
8 url = "https://github.com/LonamiWebs/Telethon";
9 ref = "sync-stale";
10 rev = "6a785a01aa56cfd21c8c5beb9d722c68d664ba5e";
11 };
12
13 propagatedBuildInputs = [
14 rsa pyaes async_generator
15 ];
16 doCheck = false;
17
18 meta = with lib; {
19 homepage = https://github.com/LonamiWebs/Telethon;
20 description = "Full-featured Telegram client library for Python 3";
21 license = licenses.mit;
22 };
23 }