]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/tools/tools/default.nix
Add yourls
[perso/Immae/Config/Nix.git] / virtual / modules / websites / tools / tools / default.nix
index 294959c72455c50138426845d58d3a434817dd99..7fb4974bd7687a006ca5fe85876e1c4dc07c3575 100644 (file)
@@ -8,6 +8,10 @@ let
     };
     roundcubemail = pkgs.callPackage ./roundcubemail.nix { env = myconfig.env.tools.roundcubemail; };
     wallabag = pkgs.callPackage ./wallabag.nix { env = myconfig.env.tools.wallabag; };
+    yourls = pkgs.callPackage ./yourls.nix {
+      inherit (mylibs) fetchedGithub;
+      env = myconfig.env.tools.yourls;
+    };
 
     cfg = config.services.myWebsites.tools.tools;
 in {
@@ -23,7 +27,8 @@ in {
       ++ ympd.apache.modules
       ++ ttrss.apache.modules
       ++ roundcubemail.apache.modules
-      ++ wallabag.apache.modules;
+      ++ wallabag.apache.modules
+      ++ yourls.apache.modules;
 
     services.ympd = ympd.config // { enable = false; };
 
@@ -37,6 +42,7 @@ in {
         ttrss.apache.vhostConf
         roundcubemail.apache.vhostConf
         wallabag.apache.vhostConf
+        yourls.apache.vhostConf
       ];
     };
 
@@ -45,12 +51,14 @@ in {
       ttrss = ttrss.phpFpm.pool;
       roundcubemail = roundcubemail.phpFpm.pool;
       wallabag = wallabag.phpFpm.pool;
+      yourls = yourls.phpFpm.pool;
     };
 
     system.activationScripts = {
       ttrss = ttrss.activationScript;
       roundcubemail = roundcubemail.activationScript;
       wallabag = wallabag.activationScript;
+      yourls = yourls.activationScript;
     };
 
     systemd.services.tt-rss = {