]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/default.nix
Add etherpad lite tool
[perso/Immae/Config/Nix.git] / virtual / modules / websites / default.nix
index 6b313811edc46f88004e645ee0fd0bac25f2b7f9..4d5ae23d3564f83403dfca8332c0125917f94ada 100644 (file)
@@ -1,8 +1,5 @@
 { lib, pkgs, config, mylibs, myconfig, ... }:
 let
-  mypkgs = pkgs.callPackage ../../packages.nix {
-    inherit (mylibs) checkEnv fetchedGit fetchedGithub;
-  };
   cfg = config.services.myWebsites;
   makeService = name: cfg: let
     toVhost = vhostConf: {
@@ -83,6 +80,8 @@ let
       });
     };
   };
+  makeModules = cfg: pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
+  makeExtraConfig = cfg: (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
 in
 {
   imports = [
@@ -91,16 +90,24 @@ in
     ./aten
     ./piedsjaloux
     ./connexionswing
+    ./tellesflorian
     ./tools/db
     ./tools/tools
     ./tools/dav
     ./tools/cloud
     ./tools/git
+    ./tools/mastodon
+    ./tools/mediagoblin
+    ./tools/diaspora
+    ./tools/ether
     # built using:
     # sed -e "s/services\.httpd/services\.httpdProd/g" .nix-defexpr/channels/nixpkgs/nixos/modules/services/web-servers/apache-httpd/default.nix
+    # Removed allGranted
     # And removed users / groups
     ./apache/httpd_prod.nix
     ./apache/httpd_inte.nix
+    # except for this one for users/groups
+    ./apache/httpd_tools.nix
     # Adapted from base phpfpm
     ./phpfpm
   ];
@@ -160,6 +167,9 @@ in
         #   '';
       });
       phpPackages = oldpkgs.php72Packages.override { inherit php; };
+      composerEnv = import ./commons/composer-env.nix {
+        inherit (pkgs) stdenv writeTextFile fetchurl php unzip;
+      };
     };
 
     services.myWebsites.tools.databases.enable = true;
@@ -167,6 +177,10 @@ in
     services.myWebsites.tools.dav.enable = true;
     services.myWebsites.tools.cloud.enable = true;
     services.myWebsites.tools.git.enable = true;
+    services.myWebsites.tools.mastodon.enable = true;
+    services.myWebsites.tools.mediagoblin.enable = true;
+    services.myWebsites.tools.diaspora.enable = true;
+    services.myWebsites.tools.etherpad-lite.enable = true;
 
     services.myWebsites.Chloe.production.enable = cfg.production.enable;
     services.myWebsites.Ludivine.production.enable = cfg.production.enable;
@@ -179,6 +193,7 @@ in
     services.myWebsites.Aten.integration.enable = cfg.integration.enable;
     services.myWebsites.PiedsJaloux.integration.enable = cfg.integration.enable;
     services.myWebsites.Connexionswing.integration.enable = cfg.integration.enable;
+    services.myWebsites.TellesFlorian.integration.enable = true;
 
     services.myWebsites.apacheConfig = {
       gzip = {
@@ -192,8 +207,7 @@ in
       };
       ldap = {
         modules = [ "ldap" "authnz_ldap" ];
-        # FIXME: starttls
-        extraConfig = assert mylibs.checkEnv "NIXOPS_HTTP_LDAP_PASSWORD"; ''
+        extraConfig = ''
           <IfModule ldap_module>
             LDAPSharedCacheSize 500000
             LDAPCacheEntries 1024
@@ -206,7 +220,7 @@ in
             <IfModule authnz_ldap_module>
               AuthLDAPURL          ldap://ldap.immae.eu:389/dc=immae,dc=eu STARTTLS
               AuthLDAPBindDN       cn=httpd,ou=services,dc=immae,dc=eu
-              AuthLDAPBindPassword "${builtins.getEnv "NIXOPS_HTTP_LDAP_PASSWORD"}"
+              AuthLDAPBindPassword "${myconfig.env.httpd.ldap.password}"
               AuthType             Basic
               AuthName             "Authentification requise (Acces LDAP)"
               AuthBasicProvider    ldap
@@ -225,6 +239,16 @@ in
               Require ldap-group cn=%{domain},ou=stats,cn=httpd,ou=services,dc=immae,dc=eu
             </Location>
           </Macro>
+
+          ErrorDocument 500 /maintenance_immae.html
+          ErrorDocument 501 /maintenance_immae.html
+          ErrorDocument 502 /maintenance_immae.html
+          ErrorDocument 503 /maintenance_immae.html
+          ErrorDocument 504 /maintenance_immae.html
+          Alias /maintenance_immae.html ${../../www}/maintenance_immae.html
+          ProxyPass /maintenance_immae.html !
+
+          AliasMatch "(.*)/googleb6d69446ff4ca3e5.html" ${../../www}/googleb6d69446ff4ca3e5.html
         '';
       };
       http2 = {
@@ -262,18 +286,26 @@ in
         '';
     };
 
-    # FIXME: logrotate
-    # FIXME: ipv6
     services.httpdProd = makeService "production" config.services.myWebsites.production;
-    services.myWebsites.production.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
-    services.myWebsites.production.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
+    services.myWebsites.production.modules = makeModules cfg;
+    services.myWebsites.production.extraConfig = makeExtraConfig cfg;
 
     services.httpdInte = makeService "integration" config.services.myWebsites.integration;
-    services.myWebsites.integration.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
-    services.myWebsites.integration.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
+    services.myWebsites.integration.modules = makeModules cfg;
+    services.myWebsites.integration.extraConfig = makeExtraConfig cfg;
 
-    services.httpd = makeService "tools" config.services.myWebsites.tools;
-    services.myWebsites.tools.modules = pkgs.lib.lists.flatten (pkgs.lib.attrsets.mapAttrsToList (n: v: v.modules or []) cfg.apacheConfig);
-    services.myWebsites.tools.extraConfig = (builtins.filter (x: x != null) (pkgs.lib.attrsets.mapAttrsToList (n: v: v.extraConfig or null) cfg.apacheConfig));
+    services.httpdTools = makeService "tools" config.services.myWebsites.tools;
+    services.myWebsites.tools.modules = makeModules cfg;
+    services.myWebsites.tools.extraConfig = makeExtraConfig cfg ++
+    [ ''
+        RedirectMatch ^/licen[cs]es?_et_tip(ping)?$ https://www.immae.eu/licences_et_tip.html
+        RedirectMatch ^/licen[cs]es?_and_tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
+        RedirectMatch ^/licen[cs]es?$ https://www.immae.eu/licenses_and_tipping.html
+        RedirectMatch ^/tip(ping)?$ https://www.immae.eu/licenses_and_tipping.html
+        RedirectMatch ^/(mentions|mentions_legales|legal)$ https://www.immae.eu/mentions.html
+        RedirectMatch ^/CGU$ https://www.immae.eu/CGU
+      ''
+      ]
+    ;
   };
 }