]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - virtual/modules/websites/chloe/default.nix
Move packages fils to module
[perso/Immae/Config/Nix.git] / virtual / modules / websites / chloe / default.nix
similarity index 91%
rename from virtual/modules/websites/chloe.nix
rename to virtual/modules/websites/chloe/default.nix
index 3309dd2b6dc2204346842eed3d29d70a87648d14..72a9b6fdb01667a395f30352096726e10b2e9240 100644 (file)
@@ -1,6 +1,6 @@
 { lib, pkgs, config, mylibs, ... }:
 let
-    chloe = pkgs.callPackage ../../packages/chloe.nix { inherit (mylibs) checkEnv fetchedGitPrivate; };
+    chloe = pkgs.callPackage ./chloe.nix { inherit (mylibs) checkEnv fetchedGitPrivate; };
     chloe_dev = chloe { environment = "dev"; };
     chloe_prod = chloe { environment = "prod"; };
 
@@ -15,13 +15,17 @@ in {
     };
   };
 
+  imports = [
+    ../commons/stats.nix
+  ];
+
   config = lib.mkMerge [
     (lib.mkIf cfg.production.enable {
       services.myWebsites.commons.stats.enable = true;
       services.myWebsites.commons.stats.sites = [
         {
           name = "osteopathe-cc.fr";
-          conf = ../../packages/chloe_goaccess.conf;
+          conf = ./goaccess.conf;
         }
       ];