]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/monitoring-1/base.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / monitoring-1 / base.nix
similarity index 75%
rename from modules/private/system/monitoring-1.nix
rename to systems/monitoring-1/base.nix
index dea5f45993daf1f31e896172933c7ba214e89bdf..8bfacc1079f0b8034759c863f1da1a38268f1b26 100644 (file)
@@ -1,25 +1,31 @@
-{ config, pkgs, resources, ... }:
+{ config, pkgs, lib, nixpkgs, php, secrets, ... }:
 {
-  deployment = {
-    targetUser = "root";
-    targetHost = config.hostEnv.ips.main.ip4;
-    substituteOnDestination = true;
-  };
   # ssh-keyscan monitoring-1 | nix-shell -p ssh-to-age --run ssh-to-age
   secrets.ageKeys = [ "age1dn4lzhgxusqrpjjnzm7w8ml39ptf326htuzmpqdqs2gg3wq7cqzqxuvx8k" ];
   boot.kernelPackages = pkgs.linuxPackages_latest;
-  myEnv = import ../../../nixops/secrets/environment.nix;
 
-  imports = [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix> ] ++ builtins.attrValues (import ../..);
+  imports = [
+    secrets.nixosModules.users-config-monitoring-1
+    (nixpkgs + "/nixos/modules/profiles/qemu-guest.nix")
+    ./monitoring-master.nix
+    ./monitoring.nix
+    ./status.nix
+    ./status_engine.nix
+  ];
+
+  nixpkgs.overlays = builtins.attrValues php.overlays;
+  nixpkgs.config.permittedInsecurePackages = [
+    "python-2.7.18.6" # for nagios-cli
+  ];
 
   myServices.monitoring.enable = true;
   myServices.monitoring.master = true;
   myServices.status.enable = true;
   networking = {
     firewall.enable = true;
-    interfaces."ens3".ipv4.addresses = pkgs.lib.attrsets.mapAttrsToList
-      (n: ips: { address = ips.ip4; prefixLength = 32; })
-      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips);
+    interfaces."ens3".ipv4.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
+      (n: ips: map (ip: { address = ip; prefixLength = 32; }) (ips.ip4 or []))
+      (pkgs.lib.attrsets.filterAttrs (n: v: n != "main") config.hostEnv.ips));
     interfaces."ens3".ipv6.addresses = pkgs.lib.flatten (pkgs.lib.attrsets.mapAttrsToList
       (n: ips: map (ip: { address = ip; prefixLength = (if n == "main" && ip == pkgs.lib.head ips.ip6 then 64 else 128); }) (ips.ip6 or []))
       config.hostEnv.ips);
   ];
 
   services.netdata.enable = true;
+  services.netdata.configDir."stream.conf" = config.secrets.fullPaths."netdata-stream.conf";
   services.netdata.config.web."allow dashboard from" = "localhost";
   services.netdata.config.web."allow badges from" = "*";
   services.netdata.config.web."allow streaming from" = "*";
   services.netdata.config.web."allow netdata.conf from" = "fd*";
   services.netdata.config.web."allow management from" = "fd*";
   networking.firewall.allowedTCPPorts = [ 19999 ];
-  environment.etc."netdata/stream.conf".source = config.secrets.fullPaths."netdata-stream.conf";
 
   secrets.keys = {
     "netdata-stream.conf" = {
@@ -65,5 +71,5 @@
   # database servers. You should change this only after NixOS release
   # notes say you should.
   # https://nixos.org/nixos/manual/release-notes.html
-  system.stateVersion = "20.03"; # Did you read the comment?
+  system.stateVersion = "23.05"; # Did you read the comment?
 }