]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/eldiron/websites/tools/ympd.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / tools / ympd.nix
similarity index 70%
rename from modules/private/websites/tools/tools/ympd.nix
rename to systems/eldiron/websites/tools/ympd.nix
index 531b1a90d8b888330d2214a916b5fb8e995bb022..0d8d41dbe2513f19f5fdcdeaae7c169c080cb22c 100644 (file)
@@ -1,4 +1,4 @@
-{ env }:
+{ env, config }:
 let
   ympd = rec {
     config = {
@@ -37,4 +37,18 @@ let
     };
   };
 in
-  ympd
+  ympd // {
+    monitoringPlugins = [ "http" ];
+    monitoringObjects.service = [
+      {
+        service_description = "mpd website is running on tools.immae.eu";
+        host_name = config.hostEnv.fqdn;
+        use = "external-web-service";
+        check_command = ["check_https_auth" "tools.immae.eu" "/mpd/" "<title>ympd"];
+
+        servicegroups = "webstatus-webapps";
+        _webstatus_name = "MPD (YMPD)";
+        _webstatus_url = "https://tools.immae.eu/mpd/";
+      }
+    ];
+  }