]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/eldiron/websites/tools/phpbb.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / tools / phpbb.nix
similarity index 71%
rename from modules/private/websites/tools/tools/phpbb.nix
rename to systems/eldiron/websites/tools/phpbb.nix
index 77845c33ce67796f517d73f0fee744be2055cb33..c1cbd6fb2ee7c7391f037e2b8093bb9554927224 100644 (file)
@@ -9,9 +9,22 @@ rec {
         cp -a ${phpbb}/vars/* ${varDir}
         chown -R ${apache.user}:${apache.user} ${varDir}
       fi
-      install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
     '';
   };
+  chatonsHostingProperties = {
+    file.datetime = "2022-08-21T22:50:00";
+    hosting = {
+      name = "phpBB";
+      description = "Forum software";
+      website = "https://tools.immae.eu/forum";
+      logo = "https://www.phpbb.com/favicon.ico";
+      type = "INSTANCE";
+      status.level = "OK";
+      status.description = "OK";
+      registration.load = "OPEN";
+      install.type = "PACKAGE";
+    };
+  };
   webRoot = phpbb;
   apache = rec {
     user = "wwwrun";
@@ -49,7 +62,8 @@ rec {
           # Needed to avoid clashes in browser cookies (same domain)
       "php_value[session.name]" = "PhpBBPHPSESSID";
       "php_admin_value[open_basedir]" = "${basedir}:/tmp";
-      "php_admin_value[session.save_path]" = "${varDir}/phpSessions";
+      "php_admin_value[session.save_handler]" = "redis";
+      "php_admin_value[session.save_path]" = "'unix:///run/redis-php-sessions/redis.sock?persistent=1&prefix=Tools:PhpBB:'";
     };
   };
 }