]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/eldiron/websites/mail/roundcubemail.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / mail / roundcubemail.nix
similarity index 94%
rename from modules/private/websites/tools/mail/roundcubemail.nix
rename to systems/eldiron/websites/mail/roundcubemail.nix
index 2661b5565f1ca62ad003aec9ff87cb02e8975f36..21a10fe6db77a13629efbefa0bbed6f889f744cf 100644 (file)
@@ -6,7 +6,6 @@ rec {
     text = ''
       install -m 0755 -o ${apache.user} -g ${apache.group} -d ${varDir} \
         ${varDir}/cache ${varDir}/logs
-      install -m 0750 -o ${apache.user} -g ${apache.group} -d ${varDir}/phpSessions
     '';
   };
   keys."webapps/tools-roundcube" = {
@@ -73,6 +72,7 @@ rec {
         $config['temp_dir'] = '${varDir}/cache';
         $config['mime_types'] = '${apacheHttpd}/conf/mime.types';
     '';
+    keyDependencies = [ apacheHttpd ];
   };
   webRoot = (roundcubemail.override { roundcube_config = config.secrets.fullPaths."webapps/tools-roundcube"; }).withPlugins (p: [ p.automatic_addressbook p.carddav p.contextmenu p.contextmenu_folder p.html5_notifier p.ident_switch p.message_highlight p.thunderbird_labels ]);
   apache = rec {
@@ -112,7 +112,8 @@ rec {
       "php_admin_value[upload_max_filesize]" = "200M";
       "php_admin_value[post_max_size]" = "200M";
       "php_admin_value[open_basedir]" = "${basedir}:${apacheHttpd}/conf/mime.types:/tmp";
-      "php_admin_value[session.save_path]" = "${varDir}/phpSessions";
+      "php_admin_value[session.save_handler]" = "redis";
+      "php_admin_value[session.save_path]" = "'unix:///run/redis-php-sessions/redis.sock?persistent=1&prefix=Tools:Roundcubemail:'";
     };
   };
 }