]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/eldiron/websites/cryptpad/farm.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / cryptpad / farm.nix
similarity index 96%
rename from modules/private/websites/tools/cryptpad/farm.nix
rename to systems/eldiron/websites/cryptpad/farm.nix
index b35f348fb4abfd3afa8b60e2edc7463e70a5e7c8..58393ab32ac127c3c79681f90ceb4a0fa2e54d73 100644 (file)
@@ -161,6 +161,12 @@ in
       type = lib.types.attrsOf lib.types.path;
       default = lib.genAttrs (builtins.attrNames cfg.hosts) toVhostRoot;
     };
+    vhostVarDirs = lib.mkOption {
+      description = "Instance vhosts var dirs";
+      readOnly = true;
+      type = lib.types.attrsOf lib.types.path;
+      default = lib.genAttrs (builtins.attrNames cfg.hosts) (n: "/var/lib/cryptpad/${n}");
+    };
   };
   config = {
     users.users = lib.optionalAttrs (cfg.hosts != {}) {