]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/eldiron/websites/commento/default.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / eldiron / websites / commento / default.nix
similarity index 63%
rename from modules/private/websites/tools/commento/default.nix
rename to systems/eldiron/websites/commento/default.nix
index c36255b63e487c66b3c7701411df2aa5b7c92f1a..c5131b81587df433d08c21a12bba79d8b7187393 100644 (file)
@@ -12,6 +12,31 @@ in
     enable = lib.mkEnableOption "Enable commento website";
   };
   config = lib.mkIf cfg.enable {
+    myServices.dns.zones."immae.eu".subdomains.commento =
+      with config.myServices.dns.helpers; ips servers.eldiron.ips.main;
+
+    myServices.chatonsProperties.services.commento = {
+      file.datetime = "2022-08-21T01:11:00";
+      service = {
+        name = "Commento";
+        description = "Commento is a fast, privacy-focused commenting platform";
+        website = "https://commento.immae.eu";
+        logo = "https://commento.immae.eu/images/logo.svg";
+        status.level = "OK";
+        status.description = "OK";
+        registration."" = ["MEMBER" "CLIENT"];
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "Commento";
+        website = "https://www.commento.io/";
+        license.url = "https://gitlab.com/commento/commento/-/blob/master/LICENSE";
+        license.name = "MIT License";
+        version = pkgs.commento.version;
+        source.url = "https://gitlab.com/commento/commento";
+      };
+    };
     secrets.keys = {
       "commento/env" = {
         permissions = "0400";
@@ -31,9 +56,9 @@ in
       };
     };
 
+    security.acme.certs.eldiron.extraDomainNames = [ "commento.immae.eu" ];
     services.websites.env.tools.vhostConfs.commento = {
       certName = "eldiron";
-      addToCerts = true;
       hosts = [ "commento.immae.eu" ];
       root = null;
       extraConfig = [