]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - systems/backup-2/databases/postgresql_replication.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / systems / backup-2 / databases / postgresql_replication.nix
similarity index 88%
rename from modules/private/databases/postgresql_replication.nix
rename to systems/backup-2/databases/postgresql_replication.nix
index 135bbed0d90bfbc9cd239727ab3ddbfc5a88e649..5351a4f0053dee1438bb5e31b903534c177cce6e 100644 (file)
@@ -50,6 +50,26 @@ in
   };
 
   config = lib.mkIf cfg.enable {
+    myServices.chatonsProperties.hostings.postgresql-replication = {
+      file.datetime = "2022-08-27T15:00:00";
+      hosting = {
+        name = "PostgreSQL replication";
+        description = "Replication of PostgreSQL database";
+        website = "db-1.immae.eu";
+        status.level = "OK";
+        status.description = "OK";
+        registration.load = "OPEN";
+        install.type = "PACKAGE";
+      };
+      software = {
+        name = "PostgreSQL";
+        website = "https://www.postgresql.org/";
+        license.url = "https://www.postgresql.org/about/licence/";
+        license.name = "The PostgreSQL Licence";
+        version = pkgs.postgresql.version;
+        source.url = "https://git.postgresql.org/gitweb/?p=postgresql.git;a=summary";
+      };
+    };
     users.users.postgres = {
       name = "postgres";
       uid = config.ids.uids.postgres;
@@ -90,6 +110,7 @@ in
           unix_socket_directories = '${dataDir}'
           data_directory = '${dataDir}'
           wal_level = logical
+          max_connections = 300
           '';
       })
     ]) cfg.hosts));