]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/woob/default.nix
Move packages to flakes
[perso/Immae/Config/Nix.git] / pkgs / woob / default.nix
diff --git a/pkgs/woob/default.nix b/pkgs/woob/default.nix
deleted file mode 100644 (file)
index 22928b9..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-{ lib
-, buildPythonPackage
-, fetchPypi
-, isPy27
-, Babel
-, colorama
-, cssselect
-, dateutil
-, feedparser
-, gdata
-, gnupg
-, html2text
-, libyaml
-, lxml
-, mechanize
-, nose
-, pdfminer
-, pillow
-, prettytable
-, pyqt5
-, pyyaml
-, requests
-, simplejson
-, termcolor
-, unidecode
-}:
-
-buildPythonPackage rec {
-  pname = "woob";
-  version = "3.0";
-  disabled = isPy27;
-
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "09hpxy5zhn2b8li0xjf3zd7s46lawb0315p5mdcsci3bj3s4v1j7";
-  };
-
-  nativeBuildInputs = [ pyqt5 ];
-
-  propagatedBuildInputs = [
-    Babel
-    colorama
-    cssselect
-    dateutil
-    feedparser
-    gdata
-    gnupg
-    html2text
-    libyaml
-    lxml
-    mechanize
-    pdfminer
-    pillow
-    prettytable
-    pyqt5
-    pyyaml
-    requests
-    simplejson
-    termcolor
-    unidecode
-  ];
-
-  doCheck = false;
-
-  meta = with lib; {
-    homepage = "https://woob.tech";
-    description = "Collection of applications and APIs to interact with websites without requiring the user to open a browser";
-    license = licenses.lgpl3Plus;
-    maintainers = [ maintainers.DamienCassou ];
- };
-}
-