]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/webapps/yourls/default.nix
Use new withPlugin system
[perso/Immae/Config/Nix.git] / pkgs / webapps / yourls / default.nix
index 4bcfa4cc8d5b91bec6b4ed9d6de4b30060143da6..d940c54d1b505ebeeadb0b876c71b726775dda9d 100644 (file)
@@ -1,16 +1,21 @@
-{ yourls_config ? "/etc/yourls/config.php", mylibs, stdenv }:
+{ yourls_config ? "/etc/yourls/config.php", mylibs, callPackage, lib, stdenv }:
 let
-  withPlugins = plugins: package.overrideAttrs(old: {
-    name = "${old.name}-with-plugins";
-    installPhase = old.installPhase +
-      builtins.concatStringsSep "\n" (
-        map (value: "ln -s ${value} $out/user/plugins/${value.pluginName}") plugins
-      );
-    passthru = old.passthru // {
-      inherit plugins;
-      withPlugins = morePlugins: old.withPlugins (morePlugins ++ plugins);
-    };
-  });
+  pluginNames = [ "ldap" ];
+  allPlugins = lib.attrsets.genAttrs pluginNames
+    (name: callPackage (./plugins + "/${name}") { inherit mylibs; });
+  toPassthru = pkg: plugins: {
+    inherit plugins allPlugins;
+    withPlugins = withPlugins pkg;
+  };
+  withPlugins = pkg: toPlugins:
+    let
+      plugins = toPlugins allPlugins;
+      toInstallPlugin = n: "ln -s ${n} $out/user/plugins/${n.pluginName}";
+      newYourls = pkg.overrideAttrs(old: {
+        installPhase = old.installPhase + "\n" + builtins.concatStringsSep "\n" (map toInstallPlugin plugins);
+        passthru = toPassthru newYourls (pkg.plugins ++ plugins);
+      });
+    in newYourls;
   package = stdenv.mkDerivation (mylibs.fetchedGithub ./yourls.json // rec {
     installPhase = ''
       mkdir -p $out
@@ -18,9 +23,6 @@ let
       cp sample-robots.txt $out/robots.txt
       ln -sf ${yourls_config} $out/includes/config.php
     '';
-    passthru = {
-      plugins = [];
-      inherit withPlugins;
-    };
+    passthru = toPassthru package [];
   });
 in package