]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/webapps/peertube/default.nix
Add syden peertube website
[perso/Immae/Config/Nix.git] / pkgs / webapps / peertube / default.nix
index 7889ceeb23f5feb93a472ebff8ecaead0d79f2f0..3642a4477b1f26a6416f80a9815f2cc31d560266 100644 (file)
@@ -1,4 +1,4 @@
-{ ldap ? false, sendmail ? false, light ? null, runCommand, libsass
+{ ldap ? false, sendmail ? false, light ? null, syden ? false, runCommand, libsass
 , lib, stdenv, rsync, fetchzip, youtube-dl, fetchurl, mylibs, python, nodejs, nodePackages, yarn2nix-moretea }:
 let
   nodeHeaders = fetchurl {
@@ -8,7 +8,10 @@ let
   source = mylibs.fetchedGithub ./peertube.json;
   patchedSource = stdenv.mkDerivation (source // rec {
     phases = [ "unpackPhase" "patchPhase" "installPhase" ];
-    patches = [ ./yarn_fix_http_node.patch ] ++ lib.optionals ldap [ ./ldap.patch ] ++ lib.optionals sendmail [ ./sendmail.patch ];
+    patches = [ ./yarn_fix_http_node.patch ]
+      ++ lib.optionals ldap [ ./ldap.patch ]
+      ++ lib.optionals sendmail [ ./sendmail.patch ]
+      ++ lib.optionals syden [ ./syden.patch ];
     installPhase = let
       # Peertube supports several languages, but they take a very long
       # time to build. The build script accepts --light which builds
@@ -37,9 +40,6 @@ let
   '';
 
   yarnModulesConfig = {
-    # all = {
-    #   buildInputs = [ yarn2nix-moretea.yarn2nix.src ];
-    # };
     bcrypt = {
       buildInputs = [ nodePackages.node-pre-gyp ];
       postInstall = let