]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/webapps/nextcloud/default.nix
Add bakeer’s website
[perso/Immae/Config/Nix.git] / pkgs / webapps / nextcloud / default.nix
index 12134943cf746683946c3b956f2fd056ca11b586..5017fd23b392b8dfdfb5ddd3cde60b7292c80211 100644 (file)
@@ -1,10 +1,11 @@
 { varDir ? "/var/lib/nextcloud", nextcloudVersion ? 18, otherConfig ? {}, lib, stdenv, callPackage, fetchzip, fetchurl }:
 let
   appNames = [
-    "apporder" "audioplayer" "bookmarks" "calendar" "carnet" "contacts"
-    "cookbook" "deck" "extract" "files_markdown" "files_readmemd"
-    "flowupload" "gpxedit" "gpxpod" "keeweb" "maps" "metadata" "music"
-    "notes" "ocsms" "passman" "polls" "spreed" "tasks"
+    "apporder" "audioplayer" "bookmarks" "calendar" "carnet" "circles"
+    "contacts" "cookbook" "deck" "extract" "files_markdown"
+    "files_readmemd" "flowupload" "gpxedit" "gpxpod" "impersonate"
+    "keeweb" "maps" "metadata" "music" "notes" "ocsms" "passman" "polls"
+    "spreed" "social" "tasks"
   ];
   allApps = lib.attrsets.genAttrs appNames
     (name: callPackage (./apps + "/${name}.nix") { inherit buildApp nextcloudVersion; });
@@ -52,7 +53,8 @@ let
       mkdir -p $out/
       cp -R . $out/
       rm -r $out/config
-      ln -sf ${varDir}/config $out/config
+      '' + lib.optionalString (varDir != null) ''
+        ln -sf ${varDir}/config $out/config
       '';
 
     passthru = toPassthru package [] otherConfig;