]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/webapps/nextcloud/default.nix
Fix music nextcloud app
[perso/Immae/Config/Nix.git] / pkgs / webapps / nextcloud / default.nix
index c3471fe6b35989e74bc2c2ec7df8948b93c6b739..12134943cf746683946c3b956f2fd056ca11b586 100644 (file)
@@ -1,32 +1,51 @@
-{ varDir ? "/var/lib/nextcloud", lib, stdenv, fetchurl }:
+{ varDir ? "/var/lib/nextcloud", nextcloudVersion ? 18, otherConfig ? {}, lib, stdenv, callPackage, fetchzip, fetchurl }:
 let
-  buildApp = { appName, version, url, sha256, installPhase ? "mkdir -p $out && cp -R . $out/" }:
+  appNames = [
+    "apporder" "audioplayer" "bookmarks" "calendar" "carnet" "contacts"
+    "cookbook" "deck" "extract" "files_markdown" "files_readmemd"
+    "flowupload" "gpxedit" "gpxpod" "keeweb" "maps" "metadata" "music"
+    "notes" "ocsms" "passman" "polls" "spreed" "tasks"
+  ];
+  allApps = lib.attrsets.genAttrs appNames
+    (name: callPackage (./apps + "/${name}.nix") { inherit buildApp nextcloudVersion; });
+  buildApp = { appName, version, url, sha256, zip ? false, otherConfig ? {}, installPhase ? "mkdir -p $out && cp -R . $out/" }:
     stdenv.mkDerivation rec {
       name = "nextcloud-app-${appName}-${version}";
       inherit version;
       phases = "unpackPhase installPhase";
       inherit installPhase;
-      src = fetchurl { inherit url sha256; };
-      passthru.appName = appName;
+      src = (if zip then fetchzip else fetchurl) { inherit url sha256; };
+      passthru = {
+        inherit appName otherConfig;
+      };
     };
-  withApps = apps: package.overrideAttrs(old: {
-    name = "${old.name}-with-apps";
-
-    installPhase = old.installPhase + (
-      builtins.concatStringsSep "\n" (
-        map (value: "ln -sf ${value} $out/apps/${value.appName}") apps
-      ));
-    passthru.apps = apps;
-    passthru.withApps = moreApps: old.withApps (moreApps ++ apps);
-  });
-
+  toPassthru = pkg: apps: otherConfig: {
+    inherit apps otherConfig allApps buildApp varDir;
+    withApps = withApps pkg;
+  };
+  withApps = pkg: toApps:
+    let
+      apps = toApps allApps;
+      toInstallApp = n: ''
+        ln -sf ${n} $out/apps/${n.appName}
+      '';
+      zipped = lib.attrsets.zipAttrs ([pkg.otherConfig or {}] ++ map (v: v.otherConfig) apps);
+      appConfigs = with lib.attrsets; with lib.lists; {
+        mimetypealiases = foldr (h: prev: prev // h) {} (zipped.mimetypealiases or []);
+        mimetypemapping = mapAttrs (_: v: unique (flatten v)) (zipAttrs (zipped.mimetypemapping or []));
+      };
+      newNextcloud = pkg.overrideAttrs(old: {
+        installPhase = old.installPhase + "\n" + builtins.concatStringsSep "\n" (map toInstallApp apps);
+        passthru = toPassthru newNextcloud (pkg.apps ++ apps) appConfigs;
+      });
+    in newNextcloud;
   package = stdenv.mkDerivation rec {
     name = "nextcloud-${version}";
-    version = "15.0.4";
+    version = "${builtins.toString nextcloudVersion}.0.4";
 
     src = fetchurl {
       url = "https://download.nextcloud.com/server/releases/${name}.tar.bz2";
-      sha256 = "0xwg7p31y1pkjk1pzygh9shpqxnfkafrab52j7in7xblq53v0zgq";
+      sha256 = "0aa3f4xbkzacfw0h9aic0ywk5mqlwka83qaszizj8lmk68kf3n7s";
     };
 
     installPhase = ''
@@ -36,10 +55,7 @@ let
       ln -sf ${varDir}/config $out/config
       '';
 
-    passthru = {
-      apps = [];
-      inherit buildApp withApps varDir;
-    };
+    passthru = toPassthru package [] otherConfig;
     meta = {
       description = "Sharing solution for files, calendars, contacts and more";
       homepage = https://nextcloud.com;