]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/webapps/default.nix
Migrate mantisbt to pkgs
[perso/Immae/Config/Nix.git] / pkgs / webapps / default.nix
index 7e04e8d498d4a558f365769d3a7d70365bcc80b0..eb01a186a6ed0e37f3985609b4193fb23fc9168f 100644 (file)
@@ -23,4 +23,14 @@ rec {
       (name: callPackage (./nextcloud/apps + "/${name}.nix") { buildApp = nextcloud.buildApp; });
 
   phpldapadmin = callPackage ./phpldapadmin {};
+
+  rompr = callPackage ./rompr { inherit mylibs; };
+
+  mantisbt_2 = callPackage ./mantisbt_2 {};
+  mantisbt_2-with-plugins = mantisbt_2.withPlugins (builtins.attrValues mantisbt_2-plugins);
+  mantisbt_2-plugins = let
+    names = [ "slack" "source-integration" ];
+  in
+    lib.attrsets.genAttrs names
+      (name: callPackage (./mantisbt_2/plugins + "/${name}") {});
 }