]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/telegramircd/default.nix
Use mylibs explicitly in pkgs
[perso/Immae/Config/Nix.git] / pkgs / telegramircd / default.nix
index 8c8bddc60effb57006cdb027b92329211afb12de..2f1d7ca57a57e133202b3138609999fafcf95c2e 100644 (file)
@@ -1,11 +1,11 @@
-{ openssl, telethon, python3Packages, fetchedGithub }:
+{ openssl, telethon, python3Packages, mylibs }:
 with python3Packages;
 buildPythonApplication rec {
   format = "other";
   pname = "telegramircd";
   version = "master";
   propagatedBuildInputs = [ telethon aiohttp ConfigArgParse openssl ];
-  src = (fetchedGithub ./telegramircd.json).src;
+  src = (mylibs.fetchedGithub ./telegramircd.json).src;
   LD_LIBRARY_PATH = "${openssl.out}/lib";
   installPhase = ''
     install -D $src/telegramircd.py $out/bin/telegramircd