]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/status_engine/worker.nix
Upgrade nixos-unstable
[perso/Immae/Config/Nix.git] / pkgs / status_engine / worker.nix
index 6c1444949ca6d69b0f3ca8ba36cdda0ee1a091b3..1232303103c12daef4f8f5b6c42e75e102971a5d 100644 (file)
@@ -1,7 +1,6 @@
-{ stdenv, mylibs, composerEnv, fetchurl, gearmand, callPackage, php73, php73base, config_file ? "/var/lib/status_engine/ui.yml" }:
+{ stdenv, mylibs, composerEnv, fetchurl, gearmand, callPackage, php73, config_file ? "/var/lib/status_engine/ui.yml" }:
 let
-  # FIXME: present in php73.buildPecl in latest nixpkgs-unstable
-  gearman = (callPackage <nixpkgs/pkgs/build-support/build-pecl.nix> { php = php73base; }) rec {
+  gearman = php73.buildPecl rec {
     version = "2.0.6";
     pname = "gearman";
     src = fetchurl {
@@ -13,7 +12,7 @@ let
   };
 in
 (composerEnv.override {
-  php = php73.withExtensions(e: php73.enabledExtensions ++ (with php73.extensions; [gearman redis mbstring bcmath json iconv]));
+  php = php73.withExtensions({ enabled, all }: enabled ++ (with all; [gearman redis mbstring bcmath json iconv]));
 }).buildPackage (mylibs.fetchedGithub ./worker.json //
   import ./worker_php_packages.nix { inherit composerEnv fetchurl; } // rec {
     postInstall = ''