]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/notmuch/notmuch-python/default.nix
Move more packages to split files
[perso/Immae/Config/Nix.git] / pkgs / notmuch / notmuch-python / default.nix
diff --git a/pkgs/notmuch/notmuch-python/default.nix b/pkgs/notmuch/notmuch-python/default.nix
new file mode 100644 (file)
index 0000000..d639d9a
--- /dev/null
@@ -0,0 +1,16 @@
+{ stdenv, notmuch, pythonPackages }:
+stdenv.mkDerivation rec {
+  name = "notmuch-${pythonPackages.python.name}-${version}";
+  version = notmuch.version;
+  outputs = [ "out" ];
+  buildInputs = with pythonPackages; [ sphinx python ];
+  src = notmuch.src;
+  phases = [ "unpackPhase" "buildPhase" "installPhase" "fixupPhase" ];
+  buildPhase = ''
+    cd bindings/python
+    python setup.py build
+    '';
+  installPhase = ''
+    python setup.py install --prefix=$out --optimize=1
+    '';
+}